Mivec Owners Group

It is currently 16 Jul 2018 13:39

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 20 Nov 2017 18:54 
Offline

Joined: 20 Nov 2017 18:01
Posts: 1
Country: Malaysia
Not so new guy here.ive made an account just to ask about this. Have my car for 18 month already so im visiting this forum since the first day of owning this car. and sorry if this is hard to understand,but ill try my best to explain every detail in english.The problem started when my friend use my car and emptied the gas tank on his way to the gas station. After refueling things back to normal. But the next morning when i try to start my car,there's nothing happen. everything seems normal except my car wont start.all the light at the dash is dim.after waiting for 20~30 minutes. The dash light became normal again.bright as usual. At this point i can start my car,but theres no idle.engine will stop if i dont keep revving .maintaining about 2500 rpm the engine goes on and off erratically. Lower than that the engine will shutdown.. I pair my ecu with emanage blue piggyback. There a clicking sound from the emanage (clicking sound as it turn off) when i keep revving. After 2 weeks of checking, the mechanics rule out ecu as the culprit. Sent it to specialist. Airflow daughterboard replace and shmitt trigger inverted hex<this is the stuff that the specialist done.but nothing has change . The mech try another mivec ecu and my car works fine. For now i still didnt get any info about the ecu code that the mech use.will update if anything new happen.

So my question is.
1.What is wrong
2.What ecu i could use to replace it. I read this forum a lot so i know that different ecu must be pair with the exact cams.slightly different wiring. Has different engagement point etc.
3.Whats so special about this MD 420449 RS ecu. Does it matter what ecu im using if paired with emanage. Does all the specialty of this ecu thrown away when i use emanage?

Topic about MD 420449 RS ecu >> viewtopic.php?f=29&t=4542


Top
 Profile  
 
PostPosted: 30 Jan 2018 04:01 
Offline

Joined: 01 Jan 2013 08:05
Posts: 17
Country: UK
I had my 420499 RS ecu die on me in exactly the same way. If you open your ecu up and take the board out of the casing you should see where moisture has ruined the edges of the board. I'm now on my third ecu, about to go standalone as they all seem to be suffering the same fate. It's not the car leaking or anything like that. the steel case allows water to condense when cold inside the ecu and over time it kills it.


Top
 Profile  
 
PostPosted: 17 Feb 2018 18:44 
Offline
Mivec Guru

Joined: 04 Jul 2005 13:25
Posts: 1207
Location: Lower Hutt
Country: NZ
It's pretty much always the electrolytic capacitors that leak.


One7seven wrote:
Sent it to specialist. Airflow daughterboard replace and shmitt trigger inverted hex<this is the stuff that the specialist done.



You're being told porkies.

_________________
6G72 mivec Twin TDO5 20Gs up and running.
Scrapheap special making exactly 280 horses at some unknown rpm.
Engine dyno under construction.

It's easier to fool someone than it is to convince someone that they've been fooled.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group