Mivec Owners Group

It is currently 21 Sep 2018 17:07

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: how to?
PostPosted: 03 Sep 2004 19:12 
trying to remove rear shock assemblies to put in my adjustables on my gen 2.

i have got th two top bolts undone and th bottom one so th assembly is unattached, but i cant seem to get th bloody thing out there's just not enough room! i dont know what else i need to remove to get it out??? :oops:

HELP please!!!! any pix or info cheers


Top
  
 
 Post subject:
PostPosted: 03 Sep 2004 21:07 
Offline
Administrator
User avatar

Joined: 07 Dec 2003 11:38
Posts: 2068
Location: Auckland
Country: New Zealand
Haha, I know EXACTLY what your talking about. I had the same trouble when I changed my springs and it nearly drove me crazy. But, i've found if you undo the bolts that hold the sway bar on, you'll get a bit of extra movement. I'm not sure which of the bolts you've undone, but get the one off the main suspension arm and you'll be laughing.

Except when you fit the next shock. Then you'll cry when you can't get the damn thing aligned again :evil:

Been there, done that :)

_________________
1993 CB4A Lancer MR Mivec - The world's fastest Gen 1 black Lancer Mivec in Auckland with white wheels. That I own. Probably.


Top
 Profile  
 
 Post subject:
PostPosted: 04 Sep 2004 15:16 
:? GREAT!!! thats just what i wanted to hear. it just looked so much more simple than this.

do u mean th 2 little ball jointed bolts on th swaybar? i didnt know how easy it would be gettin these back on so i left it alone cause i was already shitty!!! :evil:

maybe u could pm a couple of pix pointing to th right ones, i have no digi cam so i cant post up what im thinkin cheers


Top
  
 
 Post subject:
PostPosted: 04 Sep 2004 15:29 
Offline
Administrator
User avatar

Joined: 07 Dec 2003 11:38
Posts: 2068
Location: Auckland
Country: New Zealand
Erm, not the ball joint, the frame that hold the swaybar to the chassis. There are 2 bolts that you undo and then the swaybar will be loose. Just follow the swaybar back to the main chassis.

Yeah, if you get stuck, let me know and i'll try get some pics...

_________________
1993 CB4A Lancer MR Mivec - The world's fastest Gen 1 black Lancer Mivec in Auckland with white wheels. That I own. Probably.


Top
 Profile  
 
 Post subject:
PostPosted: 06 Sep 2004 22:57 
yeah im not stuck but i think i got th right ones now cheers,
but if u could post up some pix just so i can be 100% cheers


Top
  
 
 Post subject:
PostPosted: 07 Sep 2004 21:44 
well ive got one side done :lol: :lol:
it was quite simple once i knew 4 sure what i should and shouldnt be undo-ing!!
BUT th right hand side is F**KED! :twisted: i got th strut unbolted and th sway bar, just that one big bolt to release the lower arm but its stuck fast!
ive got the nut off fine, but the bolt itself wont budge (believe me ive used excessive force :twisted: ) it appears th bolt may be rusted to th metal isert in th bush! th bush insert turns when i try 2 unscrew th bolt

any suggestions on how to free this up please !!! :?


Top
  
 
 Post subject:
PostPosted: 07 Sep 2004 21:51 
Offline
Administrator
User avatar

Joined: 07 Dec 2003 11:38
Posts: 2068
Location: Auckland
Country: New Zealand
Doh. That bolt on the lower arm shouldn't need to be 'unscrewed' as it's not threaded. I just whack mine with a hammer and the bolt flys out...

I'll try and get those pics tomorrow...:)

_________________
1993 CB4A Lancer MR Mivec - The world's fastest Gen 1 black Lancer Mivec in Auckland with white wheels. That I own. Probably.


Top
 Profile  
 
 Post subject:
PostPosted: 09 Sep 2004 23:31 
Offline
Administrator
User avatar

Joined: 07 Dec 2003 11:38
Posts: 2068
Location: Auckland
Country: New Zealand
As promised...

Image

_________________
1993 CB4A Lancer MR Mivec - The world's fastest Gen 1 black Lancer Mivec in Auckland with white wheels. That I own. Probably.


Top
 Profile  
 
 Post subject:
PostPosted: 11 Sep 2004 18:47 
cheers, that bolt that holds th suspension arm is my problem yep!!!
th nut came off fine but like i said have tried knocking it out but its stuck onto th bush insert somehow????
i may just have to bolt it all up and take it down to p&h suspension to see what can be done! i was trying to avoid this coz if i did it myself it was free!!! NOT HAPPY


Top
  
 
 Post subject:
PostPosted: 11 Sep 2004 22:08 
Offline
Administrator
User avatar

Joined: 09 Dec 2003 10:18
Posts: 4439
Location: Hamilton
Country: New Zealand
Try removing the wreight from the arm. Ie put a jack under the shock so that it doesn't push on the on arm at all and just take up the slack in the arm. Then use a drift to push the bolt out, you might need quite a good hammer and of course lots of CRC or WD40. Leave the CRC to soak overnight.

_________________
93 Cyborg R (race car)

Waikato@Heart - supporting heart kids through life
Bart Dinger Electronics


Top
 Profile  
 
 Post subject:
PostPosted: 12 Sep 2004 11:18 
Offline
Administrator
User avatar

Joined: 07 Dec 2003 11:38
Posts: 2068
Location: Auckland
Country: New Zealand
Yeah, I had a bit of trouble with the nut on that suspension arm. And I was using an impact wrench... :twisted:

_________________
1993 CB4A Lancer MR Mivec - The world's fastest Gen 1 black Lancer Mivec in Auckland with white wheels. That I own. Probably.


Top
 Profile  
 
 Post subject:
PostPosted: 14 Sep 2004 22:55 
cool i'll c how i get on with th crc!
does anyone have a part no. for th suspension bush on th lower arm as indicated in th pix above. i think mine are shot, th rubber is falling apart as well as th bolt getting seized! guess thats wot 180000 k's will do huh!!!


Top
  
 
 Post subject:
PostPosted: 14 Sep 2004 23:28 
Offline
Moderator
User avatar

Joined: 09 Jun 2004 16:33
Posts: 4460
Location: Auckland
Country: NZ
Bushes for E-CJ4A0000320 :lol:

Wheel end MR197915
Body end MR244851

The bolt goes through the shock eye so its not a mitsi part.

Or do you wnat the swaybar one too?

_________________
MIVEC Data | Mitsi's > 96 GSR (stolen) | 97 Evo 4 (sold) | 96 Cyborg-RX (crashed) | 93 Cyborg-R (sold) | 3x Mirage 4WD (sold) | 98 MIVEC Race car (sold)


Top
 Profile  
 
 Post subject:
PostPosted: 15 Sep 2004 19:13 
cool cheers rabbit :D although i wonder if we're talkin about th same thing. :?
th bolt that goes thru th shock eye is ok, its out its th one about 2"outside that on th lower arm. i just dont know what u mean about body end and wheel end.
its th bolt that is attached to th wheel hub on th bottom.

sorry to confuse, im confused!!! :? :lol:

also yes please i'll have th part no. for th swaybar bushes too, im lookin at maybe getting nolathene upgraded ones since they're all f**ked


Top
  
 
 Post subject:
PostPosted: 15 Sep 2004 22:45 
Offline
Moderator
User avatar

Joined: 09 Jun 2004 16:33
Posts: 4460
Location: Auckland
Country: NZ
the lower arm is what the bolt goes through in the picture.
wheel end is the right most bush hidden by the wheel.
body end is the end to the left.

I'll PM you some labeled pictures to look at.

_________________
MIVEC Data | Mitsi's > 96 GSR (stolen) | 97 Evo 4 (sold) | 96 Cyborg-RX (crashed) | 93 Cyborg-R (sold) | 3x Mirage 4WD (sold) | 98 MIVEC Race car (sold)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group