Mivec Owners Group

It is currently 22 Jan 2018 13:08

All times are UTC + 12 hours [ DST ]




Post new topic Reply to topic  [ 31 posts ]  Go to page Previous  1, 2, 3
Author Message
PostPosted: 01 Feb 2015 03:27 
Offline

Joined: 27 Jul 2012 02:12
Posts: 77
Country: Cayman Islands
Well what turned out to be a successful day of work turned into utter defeat

Stripped the carpet so I could get to the sheetmetal to weld in some angle iron to do the battery mounts. Found lizard eggs and a termite breeding farm :depressed:. Cleaned everything out and chipped up the sound deadening under the passenger seat


The real update though.....
Image
IT RUNS!!!

About a minute later I hit the throttle pedal from the underside (taking my foot out from under it) and the car stalled, tried starting back and it wouldn't roll over, like something was stopping it. Pulled plugs and took off the throttle bodies to take a peep. Didn't see anything wrong. Grabbed a 1/2" ratchet and tried to turn the motor by hand, I can go clock wise up to a point and counter clock wise up to a point. It appears I have bent a rod. :x

Plan is to find a 4g93 block in Florida and stuff it with Supertech 82mm B16 pistons and Manley B16 H beam rods.


Attachments:
File comment: Miata battery
6A4A9015-C866-43F1-84ED-DE39DB4EDAE3_zps0gur7emt.jpg
6A4A9015-C866-43F1-84ED-DE39DB4EDAE3_zps0gur7emt.jpg [ 143.35 KiB | Viewed 576 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 31 posts ]  Go to page Previous  1, 2, 3

All times are UTC + 12 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group